326

今天因为需要测试帝国cms的一个功能,在服务器上面安装了帝国cms,下载了7.5版本,等到安装的时候,第一步,点击“我同意”就出现以下错误了:

PHP Warning: Use of undefined constant can – assumed ‘can’ (this will throw an Error in a future version of PHP) in D:\********\e\install\data\fun.php on line 121
PHP Warning: Use of undefined constant can – assumed ‘can’ (this will throw an Error in a future version of PHP) in D:\*******\e\install\data\fun.php on line 240

这里虽然不懂具体是什么意思,但注意到那串英文字符an Error in a future version of PHP,能读懂 version of PHP这个就基本上晓得问题出在哪里了,version是版本的意思,估摸着是php版本的问题,因为是windows服务器,用建站助手直接改动以下版本,前面装的是php7.2,这里我改动到PHP7.1问题就解决了。如果是虚拟主机在虚拟主机面板进行更改。帝国CMS安装错误an Error in a future version of PHP

作者 网络

发表评论

您的电子邮箱地址不会被公开。